Issues on signing receipts - DE

Incident Report for Zettle Status Page

Resolved

This is still being looked into. Thank you for your patience.
Posted Aug 28, 2025 - 15:57 UTC

Investigating

Some merchants in Germany using Cash Registers might notice the signature on receipts missing. Our team are actively working on finding a resolution to this issue as soon as possible.
Posted Aug 28, 2025 - 14:06 UTC
This incident affected: Germany.