Status
Home
Incidents
Help Centre
Issues with accepting card payments
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved.
Posted
Mar
08
,
2025
-
10:57
UTC
Investigating
We are currently experiencing difficulties with accepting card payments in Germany, and are working on implementing a fix as soon as possible.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates. Thank you.
Posted
Mar
08
,
2025
-
10:26
UTC
This incident affected: Germany.
×
Subscribe to Incident
Subscribe to updates for
Issues with accepting card payments
via . You'll receive .