Issues with Zettle Reader on Android Devices
Incident Report for Zettle Status Page
Resolved
This issue has now been resolved by updating to our new app version 7.49.3

Thank you for your continued patience while we resolved this matter
Posted May 26, 2023 - 17:17 UTC
Identified
The issue has been identified and a fix is being implemented, we will update you shortly with more information.

Thanks for your ongoing patience.
Posted May 24, 2023 - 14:52 UTC
Investigating
We are currently experiencing difficulties with our Zettle Card Reader 1 & 2 when used with an Android device that is using an Android version below 8 and are working on implementing a fix as soon as possible.

Our merchants may notice an error message on the reader showing "Unable to Connect to Network"

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted May 24, 2023 - 07:34 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.