Delayed deposits {FR}
Incident Report for Zettle Status Page
Resolved
This incident has been resolved. All delayed funds will be included in the next scheduled payout.
Posted Nov 22, 2022 - 10:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 22, 2022 - 07:44 UTC
Investigating
There is an ongoing delay on scheduled payouts.

Our merchants will notice a delay in receiving their funds. This is due to a technical issue and we are working with highest priority to implement a fix as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Nov 21, 2022 - 21:16 UTC
This incident affected: France.