Status
Home
Incidents
Help Centre
Issues with loading backoffice
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved
Posted
Aug
05
,
2025
-
10:33
UTC
Investigating
Users might experience issues with the Zettle Backoffice not loading after logging in. The team is currently investigating this.
We are actively working on resolving the issue and will provide updates as soon as more information is available. Thank you for your patience.
Posted
Aug
05
,
2025
-
10:20
UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.
×
Subscribe to Incident
Subscribe to updates for
Issues with loading backoffice
via . You'll receive .