Issues with Paypal connected accounts deposits

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 14:33 UTC

Investigating

We are currently experiencing difficulties with some Paypal connected accounts deposits from February 24th and are working on implementing a fix as soon as possible. Some merchants may see their payout as pending in the Zettle backoffice despite the funds having been processed successfully and without delay.
Posted Feb 25, 2026 - 10:24 UTC
This incident affected: UK and France.