No bank deposit emails sent

Incident Report for Zettle Status Page

Resolved

Email notifications for payouts have resumed in all markets, including the Netherlands.
Posted Nov 07, 2025 - 06:27 UTC

Identified

We’ve identified the cause of the issue. Service has recovered across all markets except the Netherlands, where the problem is still ongoing.

Payout processing continues as normal and is not delayed.
Posted Nov 06, 2025 - 13:36 UTC

Update

We are continuing to investigate this issue.
Posted Nov 05, 2025 - 16:33 UTC

Investigating

We are currently experiencing issues with the bank deposit confirmation emails. While payouts have been processed as normal without delay, the deposit emails are currently not being sent out.

Please accept our apologies for the inconvenience, and keep an eye on our Status Page for further updates.
Posted Nov 05, 2025 - 15:43 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, and Italy.