Status
Home
Incidents
Help Centre
Issues with login - UK, US, DE, FR, NL
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved.
Posted
Apr
09
,
2025
-
06:55
UTC
Investigating
We are currently experiencing login issues for PayPal integrated merchants. We are investigating the issue.
Our apologies for the inconvenience.
Posted
Apr
08
,
2025
-
21:24
UTC
This incident affected: UK, Netherlands, Germany, and France.
×
Subscribe to Incident
Subscribe to updates for
Issues with login - UK, US, DE, FR, NL
via . You'll receive .