Product library not loading (All markets)
Incident Report for Zettle Status Page
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 15:04 UTC
Investigating
We experience issues accessing the product library on both my.zettle.com and in the app.
Posted Jun 17, 2022 - 14:10 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.