Issue with QRC Payment Payout From July 11

Incident Report for Zettle Status Page

Resolved

This incident has been resolved
Posted Jul 17, 2025 - 18:21 UTC

Update

Payouts are processing as usual, but the QRC payments are not added in them.
Posted Jul 17, 2025 - 14:34 UTC

Investigating

Merchants receiving QRC payments have not received their payouts from the 11th of July. We are currently looking into this. Thank you for your patience.
Posted Jul 17, 2025 - 12:01 UTC
This incident affected: UK and Germany.