Issues with Zettle Pro & Zettle Food and Drink
Incident Report for Zettle Status Page
Resolved
Our services have now been restored and this issue is deemed resolved. We apologise for the inconvenience this has caused.
Posted Apr 12, 2021 - 19:31 UTC
Identified
We are aware of the issue that is causing the problem. We still do not have an ETA on when a resolution will be in place for this. We will continue to update you with any further progress.
Posted Apr 12, 2021 - 18:17 UTC
Update
We are continuing to investigate the issue. We will post the next update when we have further developments. Thank you for your patience.
Posted Apr 12, 2021 - 17:11 UTC
Investigating
We are currently experiencing difficulties with Zettle PRO & Food and Drink. We are working on implementing a fix as soon as possible.

Our merchants will notice issues logging in, product management issues and reporting issues

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Apr 12, 2021 - 16:33 UTC
This incident affected: UK, Sweden, Netherlands, Spain, and Mexico.