Status
Home
Incidents
Help Centre
Issues accepting card payments - MX
Incident Report for
Zettle Status Page
Resolved
The Issue has now been resolved,
Thanks for your patience while we dealt with this matter.
Posted
Sep
25
,
2023
-
06:05
UTC
Investigating
We are currently experiencing difficulties accepting card payments. We are working with the highest priority to resolve it as soon as possible.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Thank you for your patience.
Posted
Sep
24
,
2023
-
20:31
UTC
This incident affected: Mexico.
×
Subscribe to Incident
Subscribe to updates for
Issues accepting card payments - MX
via . You'll receive .