Issue with opening "Sent invoices" in Backoffice & paying invoices

Incident Report for Zettle Status Page

Resolved

This issue has been resolved.
Posted Jul 28, 2025 - 15:53 UTC

Investigating

We are currently investigating an issue where clicking on "Sent invoices" in the Backoffice is not working. We are also looking into the issue where some users are not able to pay sent invoices. Thank you for your patience.
Posted Jul 24, 2025 - 10:08 UTC
This incident affected: UK and Germany.