Status
Home
Incidents
Help Centre
Issue with registration & onboarding
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved.
Posted
Aug
26
,
2025
-
13:33
UTC
Investigating
Some merchants may be experiencing issues with registration and onboarding. We are actively investigating the cause.
Please monitor our status page for the latest updates.
Posted
Aug
26
,
2025
-
12:37
UTC
This incident affected: Spain.
×
Subscribe to Incident
Subscribe to updates for
Issue with registration & onboarding
via . You'll receive .