Issue with Receipts Creation Delays

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Sep 06, 2025 - 13:34 UTC

Investigating

Some merchants may experience intermittent delays in receipt creation. The issue started at 12:05 CET. While some receipts are taking longer than usual to generate, all receipts are eventually created. Our team is actively working on finding a resolution to this issue as soon as possible.
Posted Sep 06, 2025 - 12:38 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, France, Spain, Italy, and Mexico.