This incident has been resolved. All pending payments from 28th and 29th November, have been successfully processed on Monday 2nd December.
We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Dec 02, 2024 - 11:04 UTC
Identified
We have identified the issue causing delays in payouts. All pending payments from 28th and 29th November, are scheduled to be processed on Monday 2nd December.
We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Nov 29, 2024 - 15:50 UTC
Update
There is an ongoing delay on scheduled payouts from November 28th and November 29th.
Our merchants will notice a delay in receiving their funds. This is due to a technical issue and we are working with the highest priority to implement a fix as soon as possible.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Nov 29, 2024 - 13:07 UTC
Update
We are continuing to investigate this issue.
Posted Nov 29, 2024 - 09:06 UTC
Investigating
There is an ongoing delay on scheduled payouts from November 28th.
Our merchants will notice a delay in receiving their funds. This is due to a technical issue and we are working with highest priority to implement a fix as soon as possible.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Nov 29, 2024 - 08:37 UTC
This incident affected: Finland, Netherlands, Germany, France, Spain, and Italy.