Issues Processing Payments
Incident Report for Zettle Status Page
Resolved
We have successfully implemented a fix and the issue no longer persists. We are deeming this incident as resolved.

Thank you for your patience.

Zettle Team
Posted Mar 18, 2023 - 20:45 UTC
Investigating
We are currently experiencing difficulties processing card payments. We are working on the highest priority to resolve it as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.

Thank you for your patience.
Posted Mar 18, 2023 - 20:24 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, and Italy.