Delayed deposits due to bank holiday (FI, NL, DE, FR, ES, IT)
Incident Report for Zettle Status Page
Resolved
This incident has been resolved.
Posted Jun 18, 2022 - 06:55 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 17, 2022 - 15:04 UTC
Monitoring
The 16th of June was a bank holiday in Germany. When this happens, the bank from which our payouts originate doesn’t process any payouts until the next banking day. This affects all markets that have Euro (€) as a currency.
Posted Jun 17, 2022 - 06:49 UTC
This incident affected: Finland, Netherlands, Germany, France, Spain, and Italy.