Delayed deposits - MX
Incident Report for Zettle Status Page
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 09:20 UTC
Update
This incident has been resolved.
Posted Aug 29, 2024 - 07:45 UTC
Investigating
There is an ongoing delay in scheduled payouts for August 28th.

Our merchants will notice a delay in receiving their funds. This is due to a technical issue, and we are working with the highest priority to resolve it as soon as possible.

We apologize for the inconvenience. Please monitor our Status Page for further updates.
Posted Aug 28, 2024 - 20:43 UTC
This incident affected: Mexico.