Issue with Currency Display in Back Office

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 21:17 UTC

Update

We are continuing to investigate this issue.
Posted Sep 25, 2025 - 18:29 UTC

Investigating

Some merchants are currently experiencing an issue where the wrong currency is displayed in the back office. Please accept our apologies for the inconvenience, and keep an eye on our Status Page for further updates.

Thank you for your patience.
Posted Sep 25, 2025 - 18:19 UTC
This incident affected: Sweden, Norway, Denmark, and Mexico.