Cash Register Sign up
Incident Report for Zettle Status Page
Resolved
This issue has now been resolved by updating to app version 7.49.1

Thank you for your continued patience while we resolved this matter.
Posted Jun 02, 2023 - 10:33 UTC
Update
We are continuing to investigate this issue.
Posted May 13, 2023 - 14:24 UTC
Investigating
The sign up from Zettle Go apps for Cash Register is leading to a 404 Error. We are aware of the issue and are working to fix this. Currently, we recommend signing up from my.zettle.com.
Posted May 05, 2023 - 10:10 UTC
This incident affected: France.