Delayed deposits in the UK, Sweden and Denmark
Incident Report for Zettle Status Page
Resolved
All payouts have been deposited.
Posted Aug 22, 2024 - 09:30 UTC
Update
Today, merchants in the UK will not see their deposits on the bank account due to the below.
Unfortunately, also merchants in Denmark will not see any deposits today due to a one day delay.
Posted Aug 21, 2024 - 07:16 UTC
Update
Update on the situation per market:
Denmark: Merchants have gotten their payouts as planned, but the backoffice data is incorrect. This will be fixed.
UK: Deposits will be one day delayed.
Sweden: Deposits will be one day delayed.
Posted Aug 20, 2024 - 07:57 UTC
Identified
Unfortunately, today's payouts in the UK, Sweden and Denmark have been delayed. The responsible team is looking into the issue.
Posted Aug 19, 2024 - 12:55 UTC