Issues with Account Registration - MX
Incident Report for Zettle Status Page
Resolved
This incident has now been resolved. Users should now be able to sign up for a Zettle Account in Mexico again. Thank you for your patience.
Posted May 31, 2023 - 08:18 UTC
Investigating
We are currently experiencing difficulties with account registrations and are working on implementing a fix as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted May 24, 2023 - 07:22 UTC
This incident affected: Mexico.