Status
Home
Incidents
Help Centre
Bank account change is down
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved.
Posted
Feb
12
,
2024
-
07:24
UTC
Investigating
Merchants are not able to change their bank account
Posted
Feb
09
,
2024
-
08:39
UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.
×
Subscribe to Incident
Subscribe to updates for
Bank account change is down
via . You'll receive .