Status
Home
Incidents
Help Centre
Issue Processing Refunds
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved as of 2PM CET. Thank you for your patience.
Posted
Feb
25
,
2026
-
15:19
UTC
Investigating
Our merchants may experience issues when trying to process transaction refunds
We are working on resolving the issue as soon as possible.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted
Feb
25
,
2026
-
13:08
UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.
×
Subscribe to Incident
Subscribe to updates for
Issue Processing Refunds
via . You'll receive .