Issues with Product Library Syncing ( SE, NO, FI, GB, DK, NL, FR )
Incident Report for Zettle Status Page
Resolved
This incident has now been resolved and all products should be appearing in the product library.
Posted Sep 23, 2022 - 14:45 UTC
Update
We are currently experiencing difficulties with our product library syncing and are working on implementing a fix as soon as possible.

Our merchants will notice that products that are created on the my.zettle portal will only appear in the inventory and on the Zettle Go App and not on the my.zettle.com Portal .

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Sep 23, 2022 - 11:29 UTC
Investigating
We are currently investigating the issue.
Posted Sep 23, 2022 - 10:45 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, and France.