Status
Home
Incidents
Help Centre
Issues with Account Registration - MX
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved.
Posted
Feb
05
,
2024
-
18:43
UTC
Monitoring
We are still seeing some failures in account registrations and are monitoring the situation.
Posted
Jan
29
,
2024
-
09:21
UTC
Investigating
We are currently experiencing difficulties with account registrations and are working on implementing a fix as soon as possible.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted
Jan
22
,
2024
-
07:50
UTC
This incident affected: Mexico.
×
Subscribe to Incident
Subscribe to updates for
Issues with Account Registration - MX
via . You'll receive .