All markets - Registrations unavailable

Incident Report for Zettle Status Page

Resolved

This issue has now been resolved, and registrations are available again. We apologise for any inconvenience this may have caused.
Posted Feb 12, 2025 - 09:27 UTC

Investigating

Our registration service has been down since 8:00 AM CET due to a technical issue. We are actively working on resolving the issue and will provide updates as soon as more information is available. Thank you for your patience.
Posted Feb 12, 2025 - 07:56 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.