Status
Home
Incidents
Help Centre
Delay in PayPal deposits
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved.
Posted
Nov
22
,
2024
-
08:55
UTC
Update
Merchants with PayPal connected accounts might experience difficulties with logging in to the app at the moment. We're looking into this.
Posted
Nov
21
,
2024
-
13:03
UTC
Investigating
We are currently experiencing difficulties with Paypal connected accounts deposits and are working finding a solution as soon as possible.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted
Nov
21
,
2024
-
12:50
UTC
This incident affected: UK, Netherlands, Germany, and France.
×
Subscribe to Incident
Subscribe to updates for
Delay in PayPal deposits
via . You'll receive .