All failed payments have now been processed successfully and paid out to the wallet.
Posted May 13, 2026 - 08:38 UTC
Identified
We are currently experiencing delays in payout processing.
Merchant funds remain secure, and all pending payouts will be processed as soon as possible. Our teams are actively working to restore normal payout timelines.
We apologise for the inconvenience and appreciate your patience while we resolve this issue.
Posted May 13, 2026 - 08:00 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.