Delayed deposits - UK

Incident Report for Zettle Status Page

Resolved

This incident has been resolved. We have received confirmation that the delayed deposits will be visible in merchants bank accounts today
Posted Mar 20, 2025 - 11:05 UTC

Update

Some of our merchants will notice a delay in receiving their funds. The payments that are supposed to be credited tomorrow (Wednesday 19th) will be credited the day after tomorrow (Thursday 20th) instead.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Mar 18, 2025 - 18:00 UTC

Investigating

There is an ongoing delay on scheduled payouts. Our merchants will notice a delay in receiving their funds.

Payments that should have been processed on Wednesday will be processed on Thursday instead.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Mar 18, 2025 - 10:49 UTC
This incident affected: UK.