Status
Home
Incidents
Help Centre
Issue with Refund Processing
Incident Report for
Zettle Status Page
Resolved
A small number of users may have seen an error when processing refunds for payments made after 16:30 CET. This has now been fully resolved. We're sorry for any inconvenience caused.
Posted
Mar
17
,
2025
-
15:30
UTC
×
Subscribe to Incident
Subscribe to updates for
Issue with Refund Processing
via . You'll receive .