Merchants are not able to add or change their Bank Account
Incident Report for Zettle Status Page
Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 16:17 UTC
Investigating
Merchants are not able to change their Bank Account at the moment as they are receiving to many verifications email, this issue is being investigated
Posted Feb 08, 2024 - 14:19 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.