Delayed deposits in Norway
Incident Report for Zettle Status Page
Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 06:54 UTC
Monitoring
Unfortunately, deposits from yesterday were late in processing for Norway, which results in the funds not being paid out today. Merchants will get their deposits on Monday instead.
Posted Aug 30, 2024 - 11:01 UTC
Identified
Unfortunately, deposits from yesterday were late in processing for Norway, which results in the funds not being paid out today. Merchants will get their deposits on Monday instead.
Posted Aug 30, 2024 - 06:56 UTC