Status
Home
Incidents
Help Centre
Issues with generating receipts - SE
Incident Report for
Zettle Status Page
Resolved
This issue has now been resolved.
Posted
Feb
24
,
2024
-
14:23
UTC
Investigating
Our merchants with cash registers are experiencing issues with getting receipts from payments in the app, since 12:30 today.
We're aware of the situation and are working on finding a resolution.
We extend our apologies for the inconvenience.
Posted
Feb
24
,
2024
-
12:38
UTC
This incident affected: Sweden.
×
Subscribe to Incident
Subscribe to updates for
Issues with generating receipts - SE
via . You'll receive .