Issues with Account Registration - MX
Incident Report for Zettle Status Page
Resolved
This incident has been resolved and new registrations are possible again
Posted Nov 16, 2022 - 21:58 UTC
Update
We are continuing to investigate this issue, we apologize for any inconvenience caused.
Posted Nov 16, 2022 - 15:59 UTC
Investigating
We are currently experiencing difficulties with Account Registrations and are working on implementing a fix as soon as possible.

Our merchants will notice they will not be able to register successfully for a new Zettle account.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Nov 15, 2022 - 20:42 UTC
This incident affected: Mexico.