Registrations issues in Mexico
Incident Report for Zettle Status Page
Resolved
This issue has been resolved as of March 29th.
Posted Apr 02, 2024 - 07:27 UTC
Investigating
We are currently experiencing issues with registrations for new users in Mexico. We are working with our supplier on a solution.
Posted Mar 26, 2024 - 09:02 UTC
This incident affected: Mexico.