Delayed deposits - UK
Incident Report for Zettle Status Page
Resolved
Our payment provider has identified and resolved the issue now. All delayed deposits from December 23rd have been successfully processed as of today.

However, due to the upcoming bank holidays and processing after the cut-off time, the funds are expected to reach our merchants' bank accounts on January 2nd, 2025.
Posted Dec 30, 2024 - 15:09 UTC
Identified
Our payment provider has confirmed that the bank deposits from December 23rd were not paid out. We have also identified the issue and are actively working to resolve it.
Posted Dec 30, 2024 - 13:19 UTC
Update
This issue is still ongoing. All payouts have been processed on our end, and we are in contact with the payment provider to identify the cause.
Posted Dec 30, 2024 - 09:34 UTC
Investigating
There is an ongoing delay for bank deposits scheduled for the 23rd of December.

Our merchants will notice a delay in receiving their funds. This is due to a technical issue and we are working with highest priority to implement a fix as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Dec 27, 2024 - 11:07 UTC
This incident affected: UK.