Receipt page in the Back office is unavailable
Incident Report for Zettle Status Page
Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 14:42 UTC
Investigating
Merchants are not able to look at their receipt in the Back Office, we are currently investigating the issue
Posted Feb 07, 2024 - 11:24 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.