Zettle update needed!

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Oct 12, 2023 - 05:31 UTC

Monitoring

Please open the App Store or Google Play and update the Zettle App today to continue taking payments. Thank you!
Posted Sep 22, 2023 - 09:26 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.