Status
Home
Incidents
Help Centre
UK merchants not seeing payouts
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved - All payouts are completed.
Posted
Sep
08
,
2025
-
12:59
UTC
Identified
The merchants affected will now receive the amount in the next 1-2 business days. We apologise for any inconvenience the delay may cause.
Posted
Sep
06
,
2025
-
16:16
UTC
Investigating
We are currently experiencing issues with some UK merchants not seeing their last Zettle payouts in their wallet. We are investigating.
Posted
Sep
05
,
2025
-
16:58
UTC
This incident affected: UK.
×
Subscribe to Incident
Subscribe to updates for
UK merchants not seeing payouts
via . You'll receive .