Issue sending emails
Incident Report for Zettle Status Page
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 05:44 UTC
Investigating
We are having issues with our email services, merchants mght not be able to send receipts, invoices, ... Furthermore Merchants might have issues receiving Z-reports.
Posted Feb 05, 2024 - 18:46 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.