Status
Home
Incidents
Help Centre
Issues with sending payment links - UK, SE, NO, FR
Incident Report for
Zettle Status Page
Resolved
This issue has been resolved.
Posted
Feb
23
,
2024
-
16:16
UTC
Investigating
We're currently experiencing issues with sending Payment Links in the app checkout.
We're aware of the situation and are working on finding a resolution.
We extend our apologies for the inconvenience.
Posted
Feb
23
,
2024
-
10:50
UTC
This incident affected: UK, Sweden, Norway, and France.
×
Subscribe to Incident
Subscribe to updates for
Issues with sending payment links - UK, SE, NO, FR
via . You'll receive .