Issues with Account Registration - MX
Incident Report for Zettle Status Page
Resolved
This incident has now been resolved.
Posted Nov 10, 2022 - 10:13 UTC
Update
We are continuing to investigate this issue.
Posted Nov 09, 2022 - 17:00 UTC
Investigating
We are currently experiencing difficulties with Account Registrations and are working on implementing a fix as soon as possible.

Our merchants will notice they will not be able to register successfully a new Zettle account.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Nov 09, 2022 - 13:58 UTC
This incident affected: Mexico.