Status
Home
Incidents
Help Centre
Clearing of American Express payments
Incident Report for
Zettle Status Page
Resolved
All payments have been cleared.
Posted
Aug
22
,
2024
-
09:30
UTC
Investigating
We are currently facing issues with clearing payments taken with American Express. We are working on the issue.
Posted
Aug
22
,
2024
-
05:25
UTC
×
Subscribe to Incident
Subscribe to updates for
Clearing of American Express payments
via . You'll receive .