Issues with the product library

Incident Report for Zettle Status Page

Resolved

This incident has been resolved. Thank you for your patience.
Posted May 13, 2023 - 17:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2023 - 17:44 UTC

Investigating

Since 14.00 we are experiencing difficulties with the product library and are working on implementing a fix as soon as possible.

Our merchants will notice:

- not being able to access the product library in the Zettle Go app.
- not being able to access the product library in the back office.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted May 13, 2023 - 14:36 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.