Status
Home
Incidents
Help Centre
Delayed payouts in the UK
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved.
Posted
Sep
02
,
2024
-
06:54
UTC
Identified
Unfortunately, our bank confirms a delay with processing the payout file for the UK. The deposits will be one day delayed.
Posted
Aug
30
,
2024
-
11:14
UTC
Investigating
We are getting reports that merchants have not received any Zettle payouts today. We are currently investigating this.
Posted
Aug
30
,
2024
-
11:02
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed payouts in the UK
via . You'll receive .