Delayed deposits {SE}
Incident Report for Zettle Status Page
Resolved
A fix was successfully implemented and the issue no longer persists. We are deeming this incident as resolved.

All merchants will have received their funds correctly.

Thank you for your patience.
Posted Sep 15, 2022 - 08:37 UTC
Investigating
There is an ongoing delay on scheduled payouts.

Our merchants will notice a delay in receiving their funds from the 14th of September. This is due to a technical issue and we are working with highest priority to implement a fix as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Sep 14, 2022 - 14:07 UTC
This incident affected: Sweden.