Issues accepting card payments - GB

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Sep 16, 2023 - 14:23 UTC

Investigating

We are currently experiencing difficulties accepting card payments. We are working in the highest priority to resolve it as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.

Thank you for your patience.
Posted Sep 16, 2023 - 13:00 UTC
This incident affected: UK.