Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2025 - 03:00 UTC
Scheduled
We will be performing a scheduled maintenance of our Reports database on Thursday 27th of February between 04.00 and 06.00 AM CET. During this time reports in the Zettle app and backoffice will be temporarily unavailable.
We apologise for any inconvenience this may cause and appreciate your understanding.
Posted Feb 25, 2025 - 14:46 UTC
This scheduled maintenance affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.